This project has moved and is read-only. For the latest updates, please go here.

ReportGenerator problem with jenkins nant script

Jul 25, 2013 at 10:39 PM
I am using Opencover and ReportGenerator for coverage. When I run ReportGenerator using nant script locally, it runs fine, but when I include the same script in jenkins project, it gives reports not specified error.
[exec] No report files specified.

Here is the script which is one of the targets on nant.

<exec program="${report_console}" workingdir="UNCpath\Test_Coverage" failonerror="false">
        <arg value="-reports:&quot;Coverage.xml&quot;"/>
        <arg value="-targetdir:&quot;CoverageReports&quot;"/>
        <arg value="-reporttypes:HTML"/>
can anyone please help me out on this. I am stuck for a long time now.
Jul 26, 2013 at 5:15 AM
Is your working directory correct? If yes, then try to place the quotes at the correct position (or leave them out, as the path does not contain any spaces):
<exec program="${report_console}" workingdir="UNCpath\Test_Coverage" failonerror="false">
        <arg value="&quot;-reports:Coverage.xml&quot;"/>
        <arg value="&quot;-targetdir:CoverageReports&quot;"/>
        <arg value="-reporttypes:HTML"/>
Jul 26, 2013 at 2:41 PM
The working directory is correct. When i run it in cmd prompt, it runs perfectly fine. But, it gives error when I include the same script in jenkins.
Is there a way i can debug it in jenkins or turn on a flag to display while to generates the report?

Error: [exec] No report files specified.
Jul 26, 2013 at 2:48 PM
I also tried placing the code to the correct position. but it gives the same error,
Jul 26, 2013 at 4:37 PM
I really don't know what's wrong here.
Perhaps it helps to specify the full path to the Coverage.xml